» AP Video Blog

Adam Plowden Video produces bespoke videos and media for local and global business, products and events, telling your story through engaging media. Video production agency in Epsom, Surrey.

Using Magic Lantern on 5D mark III firmware 1.2.3... Help!

I am very keen to hear from any Canon 5D owners that have successfully loaded Magic Lantern onto their mk III with the firmware version 1.2.3. This update is the most recent, and fixed a number of 'phenomenons' which can be found on Canon's site.

ImagePhoto from Magic Lantern website.

From what I have seen on the vast internet that most creatives using ML on the mark III have rolled back their firmware to 1.1.3, which is the most up to date fw ML can install on. The results are fantastic, especially for shooting RAW; a particular interest of mine.

ImagePhoto from EOSHD website.

If you've ever installed Magic Lantern before, you would have seen on the complete screen details of a 'Bootflag' which had been successfully changed to allow ML to run.

The problem now occurs that with the recent Canon firmware update to 1.2.3 they changed something to do with the 'Bootflag' making it difficult for ML to be loaded onto the camera.

I know nothing about programming and developing so most of what is discussed in this forum is jargon to me, but it looks like it will take some time and very smart coders to work around this rather unhelpful nudge away from 3rd party hacks to develop Magic Lantern to run on the new firmware.

http://www.magiclantern.fm/forum/index.php?topic=8764.0

Why don't I roll back my firmware to 1.1.3 you ask? I don't want to! It was installed by Canon for a reason, to make the camera as best as it can be, and I would rather avoid stepping back a number of versions just in case it compromises the camera and my work. As you know, I'm a videographer so photo updates aren't too important to me, but it is all key to keeping the camera functioning properly.

For anyone owning a Canon camera, please install Magic Lantern on it, it is an incredible plug in to assist your video and photo needs, providing you with great solutions to make shooting on a DSLR easier. You can learn more and download it here! Remember to support them too!

Please get in touch if you have been successful installing ML on firmware 1.2.3, I need you!!